Problemy z aktywacją konta
Jeśli po zarejestrowaniu się na forum nie otrzymałeś emaila z linkiem do potwierdzenia rejestracji konta skontaktuj się ze mną wysyłając email za pomocą formularza kontaktowego.

Utrata startu systemu

Premiera finalnej wersji Windows 7 odbyła się 22 października 2009. Wsparcie zakończyło się 14 stycznia 2020 r.
➜ Pobierz Windows 7
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#1 Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Mam na jednej z partycji Win7 SP1 PL 64 bit. Powziąłem decyzję o zrobieniu płyty istalacyjnej do tego systemu, tyle że wzbogaconej o drivery, i inne dodatki. Z czasem okazała się być potrzebną instalacja też win7 na innej partycji którą postanowiłem sformatować (ta drugą), na niej był 32 bitowy XP, przed tym ocaliłem plik bootsect.bak. Instalacja tego drugiego Win 7 przebiegła bez żadnych kłopotów, a po instalacji powstało startowe menu na którym mogę wybrać który z Windowsów ma startować. Tyle tylko że ten pierwszy Win7 (podstawowy dla mnie) - nie chce startować - na jego partycji nic nie było robione i nie skasowany był żaden z plików startowych. Płyta w instalacją Win7 nie chce startować, a raczej zatrzymuje się w momencie gdy kończy działanie krótki pasek z " zielonymi kwadracikami" i następnie mają być kolorowe segmenciki które mają się złożyć w flagę Windows - no właśnie - do tego już nie dochodzi - jest czarny "podświetlony" ekran. Proszę o pomoc w przywróceniu startu tego systemu.
autor: Colnet » wt 19 wrz 2023, 20:39
Ufff...dałem radę rozwiązać problem. Pożyczyłem stację CD/DVD pod USB oraz płytę z Win7 Ultimate. Uruchomienie nie było łatwe bo jak napisałem boot'owanie "wygasa" na moment mającej się pojawić flagi Windows. Postanowiłem w momencie: "Naciśnij dowolny klawisz aby uruchomić z CD" - jako ten "dowolny" nacisnąłem spację, a zaraz potem zacząłem postukiwać w F8 ..... i instalator przerzucił mnie do Trybu Awaryjnego. Na początku myślałem że to Tryb od systemu Windows, ale okazał się to być tryb z płyty instalacyjnej. Następnie wybrałem Tryb Awaryjny z Menu i dalsze 2 kliki dały mi opcję instalacji dobrze znaną - opcje wyboru jezyka środowiska trzeciej "belki" nie pamiętam - ale zawsze pojawia się to w instalacji na początku.. Dalszy klik dał mi wybór instaluj i poniżej napraw Windows. Wybrałem "Napraw", potem wiersz poleceń w którym wydałem 3 polecenia[:
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

Od razu nie poszło do końca jak trzeba i w następnym uruchomieniu z płyty DVD - wybrałem opcję wizualną naprawy Windows. "Naprawiacz" zameldował że wszystko jest OK i mogę już używać Windows co po restarcie okazało się być prawdą. Mam system cały i zdrowy. Uważam za niedorzeczną opcję że instalując Win7 na innej partycji tamta instalka psuje mi instalacje dotychczasową. To samo uważam że program bootrec nie jest w systemie tylko na płycie. Moja mała Toshiba NB510 fabrycznie nie ma CDrom'u i jak ktoś jest gdzieś w "polu" z takim przypadkiem jaki wynika z wątku to ma "pozamiatane". Bardzo dziękuję userowi WinIso za pomoc i wytrwałość w niej.
Idź do posta
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#2 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

Wygląda na to, że partycja rozruchowa Win7 SP1 PL 64 bit została nadpisana podczas instalacji Win7 na partycji z WinXP.
Trochę dziwne jest to, że płyta nie chce się uruchomić? Może podczas jej tworzenia coś poszło nie tak?
Proponuję zrobić bootowalną płytę/USB z czystem Win7 i naprawić bootloader.
https://answers.microsoft.com/pl-pl/win ... 26ed135ec2

Prawdopodobnie opcja jaka Cię powinna zainteresować to
Odbudowa magazynu BCD
Komenda: bootrec.exe /rebuildbcd
Polecenie skanuje dysk w poszukiwaniu instalacji Windows 7 i pozwala dodać daną instalacje do magazynu BCD. Komunikat, że zidentyfikowano 0 instalacji oznacza, że nie znaleziono żadnych nowych instalacji oprócz tych, które już znajdują się na liście rozruchu.
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#3 Re: Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Próbowałem to polecenie, ale zwraca komunikat że nie jest rozpoznawalnym poleceniem ani wewnętrznym ani zewnętrznym programem lub plikiem wsadowym. Pamiętam że pod XP były 3 programy związane z tym tematem przypomniałem sobie tylko jeden: bootcfg.exe , ale wydane jako polecenie zwraca że nie może znaleźć pliku boot.ini i zastanawiam się czy takiego pliku nie sfabrykować. Pozostałych dwóch poleceń nie pamiętam.
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#4 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

bootcfg.exe było używane własne za czasów WinXP i chyba Visty i na Win7 już raczej nie zadziała.
To teraz inaczej. Jak uruchomisz Win7 (ten którym zastąpiłeś WinXP) i jak wejdziesz na dysk z Win7 SP1 to czy są tam jakieś pliki?
Możesz pokazać zrzut ekranu z Zarządzania dyskami?
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#5 Re: Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Teraz na partycji Win7 która zastąpiła XP są takie pliki;

BOOTSECT.BAK
bootsqm.dat
hiberfil.sys
Ten system się uruchamia.

Na partycji "mojego" Win7 który się nie uruchamia są następujące pliki:

bootsqm.dat
hiberfil.sys
msdia80.dll
pagefile.sys

W obu przypadkach włączona była opcja pokazywania plików ukrytych.
W laptopie jest tylko jeden dysk i nie ma na nim partycji rozruchowej.
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#6 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

Chodziło mi to to, czy na obu partycjach jest poprawna struktura katalogów i plików systemu Windows.
I proszę mimo wszystko o screen z zarządzania dyskami.
Bardzo prawdopodobne, że trzeba będzie ręcznie dodać wpisy do menu rozruchowego.
Przydatny może okazać się ten program https://www.dobreprogramy.pl/easybcd,pr ... 0480422529
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#7 Re: Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Przepraszam - zapomniałem o tym printscreen'ie - oto i on:
Obrazek
Opis do tego obrazka:

Partycja nr 1 , label: Win_XP - na niej jest nowy Win 7 który się uruchamia
Partycja nr 2, label: Win_7 to "mój" Windows który stracił uruchamianie
Partycja nr 3 , bez labela , 2GB to jest partycja swap dla systemu Linux
Partycja nr 4 bez labela, 50GB partycja systemu Linux
Partycja nr 5 label: Store, to NTFS z moimi "różnościami" - magazynowa

Czy mam też zrobić printscreen'a z układu katalogów obu systemów - tam nic nie było skasowane i jak był XP to hulały oba systemy.
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#8 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

Nie wspominałeś wcześniej, że masz także Linuxa na tym samym dysku. Czy Linux uruchamia się normalnie?
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#9 Re: Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Tak - z Linuxem wszystko OK.
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#10 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

OK. To teraz zasadnicze pytanie: którego bootloadera używasz? Tego z Win7 czy tego z Linuxa. Jak wyglada ekran wyboru systemu? Jak na pierwszym screenie czy jak na drugim?

IMG_4097.png
Bootscreen #1 - Linux
IMG_4097.png (10.75 KiB) Przejrzano 2041 razy
Bootscreen #1 - Linux
Bootscreen #1 - Linux
IMG_4097.png (10.75 KiB) Przejrzano 2041 razy
Bootscreen #2 - Windows
Bootscreen #2 - Windows
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#11 Re: Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Bootloader jest kaskadowy - najpierw jet tak jak na pierwszym obrazku i gdy wybiorę Linux to wchodzi Linux, a gdy wybiorę Windows to przełącza mnie na windowsowe menu wyboru systemu i już tylko wybór jednego z dwóch Windowsów tak jak na dolnym obrazku.
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#12 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

Pierwszy raz spotykam się z taką sytuacją, że ktoś ma dwa bootloadery. Miałem już windowsa i linuxa na jednym dysku ale zazwyczaj to grub (bootloader linuxa) zajmował się wyborem systemu.
Tobie tez tak radzę aby dodać oba systemy Windows do menu wyboru linuxa.
Ewentualnie możesz spróbować użyć programu, który podlinkowałem wyżej, uruchomić Windowsa i dodać ręcznie brakujący system do bootmenu Windowsa.
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#13 Re: Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Przebudowałem to Linuxowe BootMenu na beskaskadowe, ale nic to nie dało, dalej Win7 na partycji z labekem Win_XP się uruchamia, a "mój"
Win7 się nie uruchamia.
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#14 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

A czy wpisy dotyczące Win7 na pewno się dodały do bootloadera?
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#15 Re: Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Tego nie wiem, bo nie wiem jak to sprawdzić, ale ten nowy Win7 się z tego linuxowego bootmenu uruchamia. Rozważam "najechanie" instalacją z płyty uruchomionej przez klik "setup na płycie" z tego nowego win7 na ten nie uruchamiający się Win7. Instalacje z pendrive nie mają pozycji "Napraw system". I w ogóle to jest dziwne że angielskie iso ruchamiane z pendriwe'a się uruchamiają, a polskie iso uruchamiają się częściowo, tak jak to opisałem w poscie inicjującym wątek.
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#16 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

Coś się musiało mocno namieszać w sektorze rozruchowym.
Pozostaje spróbować tego:
Uruchom linuxa, potem uruchom terminal i użyj komend sudo os-prober to polecenie przeszuka dysk w poszukiwaniu innych systemów operacyjnych a następnie sudo update-grub aby dodać znalezione systemy, których nie ma na liście.

Do zarządzania grub można użyć tego oprogramuj https://itsfoss.com/install-grub-customizer-ubuntu/

Pokaż zawartość pliku konfiguracyjnego gruba: sudo cat /boot/grub/grub.cfg
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#17 Re: Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Jak wiadomo windows podczas instalacji ruguje start innych niz windows systemów operacyjnych, więc jak się domyślasz - sztukę odzyskiwania startu systemów Linux opanowałem dość dobrze. Podczas procedury odzyskiwania wydaje nieco inne polecenie niż "os-prober" wpisuję: "grub-install --recheck /dev/sda". Plecenie "os-prober" oczywiśce wykonałem i zwraca ono taki text:

/dev/sda1:Windows 7:Windows:chain
/dev/sda2:Windows 7:Windows1:chain

Polecenie cat /boot/grub/grub.cfg zwraa tyle textu że przelałem je do pliki i skompresowałem do pliku: grub.zip (załącznik).

Do zarządzania grub można użyć tego oprogramuj https://itsfoss.com/install-grub-customizer-ubuntu/

Customizer'a używam od lat. :)

I tak sobie pomyślałem - czy nie możesz mi przysłać tego programu bootrec o którym wspomniałeś na wstępie ? E-mail jak w rejestracji. Myślę że on załatwi sprawę. Ja w obu tych windowsach nie mam tego programu, a ich wersje to: "mój" - wersja polska , a ten co się uruchamia - wersja angielska - obie wersje windows'ów to Home Premium 64 bit. Załącznik jest tu: http://universis.cba.pl/news/grub.zip
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#18 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

Faktycznie wpisy gruba wyglądają na prawidłowe. os-prober zwraca dobre wyniki czyli od strony bootloadera linuxa wszystko jest OK. Zastanawia mnie tylko co jest nie tak z partycjami windowsowymi, że tylko jedna z nich "Win_XP" bootuje prawidłowo mimo iż grub jest skonfigurowany poprawnie.
A co do programu to nie wiem czy można go sobie ot tak skopiować na USB/CD i uruchomić bo jest on częścią środowiska odzyskiwania i naprawy Windowsa i znajduje się w każdym obrazki ISO systemu oraz w już zainstalowanym systemie.
Tylko czy nie skończy się to tak, że podczas naprawy bootsektora Windows nie wysypie się GRUB?
Nie mam już pomysłu za bardzo co może być przyczyną takiego problemu.
Jedyna opcja jaka mi jeszcze przychodzi do głowy to ręczna edycja bootmenu w Win7 (tym, który się uruchamia) https://answers.microsoft.com/en-us/win ... 1111e7bfec
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
Colnet
Początkujący
Początkujący
Posty: 16
Rejestracja: sob 11 mar 2023, 18:39
Rozwiązany: 1

#19 Re: Utrata startu systemu

Nieprzeczytany post autor: Colnet »

Ufff...dałem radę rozwiązać problem. Pożyczyłem stację CD/DVD pod USB oraz płytę z Win7 Ultimate. Uruchomienie nie było łatwe bo jak napisałem boot'owanie "wygasa" na moment mającej się pojawić flagi Windows. Postanowiłem w momencie: "Naciśnij dowolny klawisz aby uruchomić z CD" - jako ten "dowolny" nacisnąłem spację, a zaraz potem zacząłem postukiwać w F8 ..... i instalator przerzucił mnie do Trybu Awaryjnego. Na początku myślałem że to Tryb od systemu Windows, ale okazał się to być tryb z płyty instalacyjnej. Następnie wybrałem Tryb Awaryjny z Menu i dalsze 2 kliki dały mi opcję instalacji dobrze znaną - opcje wyboru jezyka środowiska trzeciej "belki" nie pamiętam - ale zawsze pojawia się to w instalacji na początku.. Dalszy klik dał mi wybór instaluj i poniżej napraw Windows. Wybrałem "Napraw", potem wiersz poleceń w którym wydałem 3 polecenia[:
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

Od razu nie poszło do końca jak trzeba i w następnym uruchomieniu z płyty DVD - wybrałem opcję wizualną naprawy Windows. "Naprawiacz" zameldował że wszystko jest OK i mogę już używać Windows co po restarcie okazało się być prawdą. Mam system cały i zdrowy. Uważam za niedorzeczną opcję że instalując Win7 na innej partycji tamta instalka psuje mi instalacje dotychczasową. To samo uważam że program bootrec nie jest w systemie tylko na płycie. Moja mała Toshiba NB510 fabrycznie nie ma CDrom'u i jak ktoś jest gdzieś w "polu" z takim przypadkiem jaki wynika z wątku to ma "pozamiatane". Bardzo dziękuję userowi WinIso za pomoc i wytrwałość w niej.
Awatar użytkownika
WinISO
Administrator
Administrator
Posty: 629
Rejestracja: pt 15 sty 2021, 20:01
Rozwiązany: 8
Lokalizacja: WinISO
Podziękował: 31 razy
Podziękowano : 26 razy
Kontakt:

#20 Re: Utrata startu systemu

Nieprzeczytany post autor: WinISO »

Już to mówiłem ale powiem jeszcze raz: to trochę dziwna sytuacja. Cos musiało być dobrze namieszane w bootloaderach ze grub mimo dodanych wpisów nie uruchamiał jednego z systemów.
Dobrze że udało się to naprawic
WinISO.pl - Baza polskich wersji systemów Windows, Windows Serwer i MS Office
Windows Desktop - Windows Serwer - Windows Debloat - MS Office - Wersje Beta
ODPOWIEDZ

Utwórz konto lub zaloguj się, aby dołączyć do dyskusji

Musisz być zalogowany, aby opublikować odpowiedź

Utwórz konto

Nie masz konta? Zarejestruj się, aby dołączyć do naszej społeczności
Mając konto moesz zakładać własne tematy i subskrybować interesujące cię wątki
To nic nie kosztuje i zajmuje tylko minutę

Zarejestruj się

Zaloguj się